Введение

InfraRecorder
Введение

Добро пожаловать

Благодарим Вас за то, что Вы установили InfraRecorder! InfraRecorder - это бесплатное решение для записи CD и DVD дисков под Microsoft Windows.

Быстрая навигация

Возможности программы
Лицензионное соглашение
Системные требования
Быстрый старт
Копиирайт
Благодарности
Что нового?
Установка


Возможности программы

InfraRecorder
Возможности программы

На этой странице приведен список наиболее важных возможностей InfraRecorder.

Основные возможности

  • Создание проектов дисков с данными, музыкальных и смешанных дисков, и их запись на компакт-диски или в образы дисков.
  • Создание и запись образов дисков.
  • Создание точных копий дисков, "на лету" или с использованием временного образа диска.
  • Очистка (стирание) перезаписываемых дисков с использованием разных способов.
  • Импорт сессий с мультисессионных дисков и добавление сессий на такие диски.
  • Фиксация дисков (запись Lead-out информации для предотвращения добавление данных на диск).
  • Сканирование SCSI/IDE шин на наличие устройств, и сбор детальной информации об их возможностях.
  • Отображение детальной информации о дисках.
  • Считывание и сохранение аудио дорожек и дорожек с данными в файлы (wav. и .iso)
  • Сканирование дорожек на наличие ошибок.

Интерфейс

  • Современный, легко настраиваемый интерфейс в стиле Проводника Windows.
  • Поддержка функции Drag and drop при добавлении файлов из окна Проводника в проект.
  • Использование разных типов отображения структуры проекта для различных типов проектов, с целью облегчения работы пользователя с программой.
  • Отдельное экспресс приложение, цель которого, обеспечить максимально быстрый и простой доступ к наиболее важным инструментам.
  • Простота локализации главного и экспресс приложения, а также расширения оболочки.

Интеграция в Проводник

Интегрируется в Проводник, и добавляет в Контекстное меню новые опции.

  • Запись сохраненных проектов и образов дисков.
  • Открытие и редактирование сохраненных проектов.
  • Легко настраиваемые элементы могут отображаться как Каскадное меню, со значками или без них.
  • Расширение оболочки может быть зарегистрировано с любым расширением, по желанию пользователя.


Лицензионное соглашение

InfraRecorder
Лицензионное соглашение

GNU GENERAL PUBLIC LICENSE

Версия 2, июнь 1991г.

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
Данный лицензионный документ разрешается копировать и распространять его точные копии. Вносить какие-либо изменения в текст данного документа запрещается.

Преамбула

Лицензии на большую часть программного обеспечения (ПО), составлены так, чтобы лишить вас свободы совместно использовать и изменять его. Напротив, Универсальная Общественная Лицензия GNU предназначена гарантировать вашу свободу совместно использовать и изменять свободное ПО, т.е. удостоверить, что ПО является свободным для всех его пользователей. Эта Универсальная Общественная Лицензия применима к большей части ПО Фонда Свободного ПО и ко всем другим программам, чьи авторы принимают на себя обязательства ее использовать. (Вместо нее для части ПО Фонда Свободного ПО применяется Универсальная Общественная Лицензия GNU для библиотек.) Вы тоже можете использовать ее для своих программ.

Когда мы говорим о свободном ПО, мы имеем в виду свободу, а не цену. Предполагается, что наши Универсальные Общественные Лицензии гарантируют, что вы пользуетесь свободой распространять копии свободного ПО (и получать за это вознаграждение, если вы того желаете); что вы получаете исходный код или можете получить его, если захотите; что вы можете изменять ПО или использовать его части в новых свободных программах; и что вы знаете, что вы можете все это делать.

Чтобы защитить ваши права, нам нужно ввести такие ограничения, которые запретят кому бы то ни было отказывать вам в этих правах или потребовать от вас отказаться от этих прав. Эти ограничения переводятся в некоторые обязательства для вас, если вы распространяете копии ПО или если вы модифицируете его.

Например, если вы распространяете копии такой программы бесплатно или за вознаграждение, вы должны предоставить получателям все права, которыми вы обладаете. Вы должны гарантировать, что они тоже получат или смогут получить исходный код. И вы должны показать им эти условия, чтобы они знали о своих правах.

Мы защищаем ваши права в два этапа: (1) сохраняем авторские права на ПО и (2) предлагаем вам эту лицензию, которая дает вам законное право копировать, распространять и/или модифицировать ПО.

Также, чтобы защитить нас и каждого автора, мы хотим удостовериться, что все понимают, что гарантий на это свободное ПО нет. Если ПО модифицируется и передается кем-то еще, мы хотим, чтобы получатели ПО знали, что то, что у них есть --- это не оригинал, чтобы любые проблемы, созданные другими, не отразились на репутации первоначальных авторов.

И наконец, каждой свободной программе постоянно угрожают патенты на ПО. Мы хотим избежать опасности, что повторные распространители свободной программы самостоятельно получат патенты, делая программу таким образом частной собственностью. Чтобы предотвратить это, мы явно заявляем, что любой патент должен быть либо предоставлен всем для свободного использования, либо не предоставлен никому.

Ниже следуют точные определения и условия для копирования, распространения и модификации.

ОПРЕДЕЛЕНИЯ И УСЛОВИЯ ДЛЯ КОПИРОВАНИЯ, РАСПРОСТРАНЕНИЯ И МОДИФИКАЦИИ

0. Эта Лицензия применима к любой программе или другому произведению, содержащему уведомление, помещенное держателем авторских прав и сообщающее о том, что оно может распространяться при условиях, оговоренных в данной Универсальной Общественной Лицензии. В последующем термин "Программа" относится к любой такой программе или произведению, а термин "произведение, основанное на Программе" означает Программу или любое произведение, содержащее Программу или ее часть, дословную, или модифицированную, и/или переведенную на другой язык. (Здесь и далее перевод включается без ограничений в понятие "модификация".) Каждый обладатель лицензии адресуется как "вы".

Виды деятельности, не являющиеся копированием, распространением или модификацией не охватываются этой Лицензией; они за пределами ее влияния. Использование Программы по ее функциональному назначению не ограничено, и выходные данные Программы охватываются этой Лицензией, только если их содержание является произведением, основанным на Программе (вне зависимости от того, были ли они получены в процессе использования Программы). Являются ли они таковыми, зависит от того, что что именно делает Программа.

1. Вы можете копировать и распространять дословные копии исходного кода Программы по его получении на любом носителе, при условии что вы соответствующим образом помещаете на видном месте в каждой копии соответствующее уведомление об авторских правах и отказ от гарантий; оставляете нетронутыми все уведомления, относящиеся к данной Лицензии и к отсутствию каких-либо гарантий; и передаете всем другим получателям Программы копию данной Лицензии вместе с Программой.

Вы можете назначить плату за физический акт передачи копии и можете по своему усмотрению предоставлять гарантии за вознаграждение.

2. Вы можете изменять свою копию или копии Программы или любой ее части, создавая таким образом произведение, основанное на Программе, и копировать и распространять эти модификации или произведение в соответствии с Разделом 1, приведенным выше, при условии, что вы выполните все нижеследующие условия:

a) Вы обязаны снабдить модифицированные файлы заметными уведомлениями, содержащими указания на то, что вы изменили файлы, и дату каждого изменения.
b) Вы обязаны предоставить всем третьим лицам лицензию на бесплатное использование каждого произведения, которое вы распространяете или публикуете, целиком, и которое полностью или частично содержит Программу или какую-либо ее часть, на условиях, оговоренных в данной Лицензии.
c) Если модифицированная программа обычно читает команды в интерактивном режиме работы, вы должны сделать так, чтобы при запуске для работы в таком интерактивном режиме обычным для нее способом она печатала или выводила на экран объявление, содержащее соответствующее уведомление об авторских правах и уведомление о том, что гарантий нет (или, наоборот, сообщающее о том, что вы обеспечиваете гарантии), и что пользователи могут повторно распространять программу при этих условиях, и указывающее пользователю, как просмотреть копию данной Лицензии. (Исключение: если сама Программа работает в интерактивном режиме, но обычно не выводит подобное объявление, то ваше произведение, основанное на Программе, не обязано выводить объявление.)

Эти требования применяются к модифицированному произведению в целом. Если известные части этого произведения не были основаны на Программе и могут обоснованно считаться независимыми и самостоятельными произведениями, то эта Лицензия и ее условия не распространяются на эти части, если вы распространяете их как отдельные произведения. Но если вы распространяете эти части как часть целого произведения, основанного на Программе, то вы обязаны делать это в соответствии с условиями данной Лицензии, распространяя права получателей лицензии на все произведение и, таким образом, на каждую часть, вне зависимости от того, кто ее написал.

Таким образом, содержание этого раздела не имеет цели претендовать на ваши права на произведение, написанное полностью вами, или оспаривать их; цель скорее в том, чтобы развить право управлять распространением производных или коллективных произведений, основанных на Программе.

Кроме того, простое нахождение другого произведения, не основанного на этой Программе, совместно с Программой (или с произведением, основанным на этой Программе) на том же носителе для постоянного хранения или распространяемом носителе не распространяет действие этой Лицензии на другое произведение.

3. Вы можете копировать и распространять Программу (или произведение, основанное на ней) согласно Разделу 2) в объектном коде или в выполнимом виде в соответствии с Разделами 1 и 2, приведенными выше, при условии, что вы также выполните одно из следующих требований:

a) Сопроводите ее полным соответствующим машиночитаемым исходным кодом, который должен распространяться в соответствии с Разделами 1 и 2, приведенными выше, на носителе, обычно используемом для обмена ПО; или,
b) Сопроводите ее письменным предложением, действительным по крайней мере в течение трех лет, предоставить любому третьему лицу за вознаграждение не большее стоимости физического акта изготовления копии полную машиночитаемую копию соответствующего исходного кода, подлежащую распространению в соответствии с Разделами 1 и 2, приведенными выше; или,
c) Сопроводите ее информацией, полученной вами в качестве предложения распространить соответствующий исходный код. (Эта возможность допустима только для некоммерческого распространения, и только если вы получили программу в объектном коде или в выполнимом виде с предложением в соответствии с Пунктом b) выше)

Исходный код для призведения означает его вид, предпочтительный для выполнения в нем модификаций. Для исполняемого произведения полный исходный код означает все исходные коды для всех модулей, которые он содержит, плюс любые связанные с произведением файлы определения интерфейса, плюс сценарии, используемые для управления компиляцией и установкой исполняемого произведения. Однако, в виде особого исключения распространяемый исходный код не обязан включать то, что обычно предоставляется с основными компонентами операционной системы, под управлением которой работает исполняемое произведение, за исключением случая, когда сам компонент сопровождает исполняемое произведение.

Если распространение исполняемого произведения или объектного кода происходит путем предоставления доступа для копирования с обозначенного места, то предоставление доступа для копирования исходного кода с того же места считается распространением исходного кода, даже если третьи лица не принуждаются к копированию исходного кода вместе с объектным кодом.

4. Вы не можете копировать, изменять, повторно лицензировать, или распространять Программу иначе, чем это явно предусмотрено данной Лицензией. Любая попытка копировать, изменять, повторно лицензировать, или распространять Программу каким-либо другим способом неправомерна и автоматически прекращает ваши права данные вам этой Лицензией. Однако лицензии лиц, получивших от вас копии или права согласно данной Универсальной Общественной Лицензии, не прекратят своего действия до тех пор, пока эти лица полностью соблюдают условия.

5. Вы не обязаны соглашаться с этой Лицензией, так как вы не подписывали ее. Однако тогда вы не получаете права модифицировать или распространять Программу или основанные на Программе произведения. Эти действия запрещены законом, если вы не принимаете к соблюдению эту Лицензию. А значит, изменяя или распространяя Программу (или произведение, основанное на Программе), вы изъявляете свое согласие с этой Лицензией и всеми ее условиями о копировании, распространении или модификации Программы или произведений, основанных на ней.

6. Каждый раз, когда вы повторно распространяете Программу (или любое произведение, основанное на Программе), получатель автоматически получает лицензию от первоначального держателя лицензии на копирование, распространение или модификацию Программы, обсуждаемую в этих определениях и условиях. Вы не можете налагать каких-либо дополнительных ограничений на осуществление получателем прав, предоставленных данным документом. Вы не несете ответстенности за соблюдение третьими лицами условий этой Лицензии.

7. Если в результате судебного разбирательства, или обвинения в нарушении патента или по любой другой причине (не обязательно связанной с патентами), вам навязаны условия, противоречащие данной Лицензии (как по решению суда, так и нет), то это не освобождает вас от соблюдения Лицензии. Если вы не можете заниматься распространением так, чтобы одновременно удовлетворить требованиям и этой Лицензии, и всем другим требованиям, то вы не должны заниматься распространением Программы. Например, если патент не позволяет безвозмездное повторное распространение Программы всем, кто получил копии от вас непосредственно или через посредников, то единственным способом удовлетворить и патенту, и этой Лицензии будет ваш полный отказ от распространения Программы.

Если какая-либо часть этого раздела не имеет силы или не может быть применена при любых конкретных обстоятельствах, то подразумевается, что имеет силу остальная часть раздела, и весь Раздел имеет силу при других обстоятельствах.

Цель этого раздела не побудить вас делать заявления о нарушениях прав на патент, или других претензиях на право собственности, или оспаривать правильность подобных претензий; единственная цель этого раздела --- защита целостности системы распространения свободного ПО, которая реализуется использованием общих лицензий. Многие люди благодаря этой системе внесли щедрый вклад в широкий спектр распространяемого ПО полагаясь на согласованное применение этой системы; автору принадлежит право решать хочет ли он или она распространять ПО в этой системе или в какой-то другой, и получатель лицензии не может влиять на принятие этого решения.

Этот раздел предназначен для того, чтобы тщательно прояснить, что полагается следствием из остальной части данной Лицензии.

8. Если распространение и/или применение Программы ограничено в ряде стран либо патентами, либо авторскими правами на интерфейсы, первоначальный обладатель авторских прав, выпускающий Программу с этой Лицензией, может добавить явное ограничение на географическое распространение, исключив такие страны, так что распространение разрешается только в тех странах, которые не были исключены. В этом случае данная Лицензия включает в себя это ограничение, как если бы оно было написано в тексте данной Лицензии.

9. Фонд Свободного ПО может время от времени публиковать пересмотренные и/или новые версии Универсальной Общественной Лицензии. Такие новые версии будут сходны по духу с настоящей версией, но могут отличаться в деталях, направленных на новые проблемы или обстоятельства.

Каждой версии придается отличительный номер версии. Если в Программе указан номер версии данной Лицензии, которая к ней применима, и слова "любая последующая версия", вы можете по выбору следовать определениям и условиям либо данной версии, либо любой последующей версии, опубликованной Фондом Свободного ПО. Если в Программе не указан номер версии данной Лицензии, вы можете выбрать любую версию, когда-либо опубликованную Фондом Свободного ПО.

10. Если вы хотите встроить части Программы в другие свободные программы с иными условиями распространения, напишите автору с просьбой о разрешении. Для ПО, которое охраняется авторскими правами Фонда Свободного ПО, напишите в Фонд Свободного ПО; мы иногда делаем исключения для этого. Наше решение будет руководствоваться двумя целями: сохранения свободного статуса всех производных нашего свободного ПО и содействия совместному и повторному использованию ПО вообще.

НИКАКИХ ГАРАНТИЙ

11. ПОСКОЛЬКУ ПРОГРАММА ПРЕДОСТАВЛЯЕТСЯ БЕСПЛАТНО, НА ПРОГРАММУ НЕТ ГАРАНТИЙ В ТОЙ МЕРЕ, КАКАЯ ДОПУСТИМА ПРИМЕНИМЫМ ЗАКОНОМ. ЗА ИСКЛЮЧЕНИЕМ ТЕХ СЛУЧАЕВ, КОГДА ПРОТИВНОЕ ЗАЯВЛЕНО В ПИСЬМЕННОЙ ФОРМЕ, ДЕРЖАТЕЛИ АВТОРСКИХ ПРАВ И/ИЛИ ДРУГИЕ СТОРОНЫ ПОСТАВЛЯЮТ ПРОГРАММУ "КАК ОНА ЕСТЬ" БЕЗ КАКОГО-ЛИБО ВИДА ГАРАНТИЙ, ВЫРАЖЕННЫХ ЯВНО ИЛИ ПОДРАЗУМЕВАЕМЫХ, ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯСЬ ПОДРАЗУМЕВАЕМЫМИ ГАРАНТИЯМИ КОММЕРЧЕСКОЙ ЦЕННОСТИ И ПРИГОДНОСТИ ДЛЯ КОНКРЕТНОЙ ЦЕЛИ. ВЕСЬ РИСК В ОТНОШЕНИИ КАЧЕСТВА И ПРОИЗВОДИТЕЛЬНОСТИ ПРОГРАММЫ ОСТАЕТСЯ ПРИ ВАС. ЕСЛИ ПРОГРАММА ОКАЖЕТСЯ ДЕФЕКТИВНОЙ, ВЫ ПРИНИМАЕТЕ НА СЕБЯ СТОИМОСТЬ ВСЕГО НЕОБХОДИМОГО ОБСЛУЖИВАНИЯ, ВОССТАНОВЛЕНИЯ ИЛИ ИСПРАВЛЕНИЯ.

12. И В КОЕМ СЛУЧАЕ, ЕСЛИ НЕ ТРЕБУЕТСЯ ПОДХОДЯЩИМ ЗАКОНОМ ИЛИ НЕ УСЛОВЛЕНО В ПИСЬМЕННОЙ ФОРМЕ, НИКАКОЙ ДЕРЖАТЕЛЬ АВТОРСКИХ ПРАВ ИЛИ НИКАКОЕ ДРУГОЕ ЛИЦО, КОТОРОЕ МОЖЕТ ИЗМЕНЯТЬ И/ИЛИ ПОВТОРНО РАСПРОСТРАНЯТЬ ПРОГРАММУ, КАК БЫЛО РАЗРЕШЕНО ВЫШЕ, НЕ ОТВЕТСТВЕННЫ ПЕРЕД ВАМИ ЗА УБЫТКИ, ВКЛЮЧАЯ ЛЮБЫЕ ОБЩИЕ, СПЕЦИАЛЬНЫЕ, СЛУЧАЙНЫЕ ИЛИ ПОСЛЕДОВАВШИЕ УБЫТКИ, ПРОИСТЕКАЮЩИЕ ИЗ ИСПОЛЬЗОВАНИЯ ИЛИ НЕВОЗМОЖНОСТИ ИСПОЛЬЗОВАНИЯ ПРОГРАММЫ (ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯСЬ ПОТЕРЕЙ ДАННЫХ, ИЛИ ДАННЫМИ, СТАВШИМИ НЕПРАВИЛЬНЫМИ, ИЛИ ПОТЕРЯМИ, ПОНЕСЕННЫМИ ИЗ-ЗА ВАС ИЛИ ТРЕТЬИХ ЛИЦ, ИЛИ ОТКАЗОМ ПРОГРАММЫ РАБОТАТЬ СОВМЕСТНО С ЛЮБЫМИ ДРУГИМИ ПРОГРАММАМИ), ДАЖЕ ЕСЛИ ТАКОЙ ДЕРЖАТЕЛЬ ИЛИ ДРУГОЕ ЛИЦО БЫЛИ ИЗВЕЩЕНЫ О ВОЗМОЖНОСТИ ТАКИХ УБЫТКОВ.

КОНЕЦ ОПРЕДЕЛЕНИЙ И УСЛОВИЙ

Как применять эти условия к вашим новым программам

Если вы разрабатываете новую программу и хотите, чтобы она принесла максимально возможную пользу обществу, лучший способ достичь этого - включить ее в свободное ПО, которое каждый может повторно распространять и изменять согласно данным условиям.

Чтобы сделать это, добавьте в программу следующие уведомления. Самое безопасное --- это добавить их в начало каждого исходного файла, чтобы наиболее эффективно отобразить исключение гарантий; и каждый файл должен содержать по меньшей мере строку, содержащую знак охраны авторского права и указание на то, где находится полное уведомление.

одна строка, содержащая название программы и краткое описание, что она делает.
Copyright (C) ГГГГ наименование (имя) автора

Это свободная программа; вы можете повторно распространять ее и/или
модифицировать ее в соответствии с Универсальной Общественной
Лицензией GNU, опубликованной Фондом Свободного ПО; либо версии 2, либо (по
вашему выбору) любой более поздней версn.

Эта программа распространяется в надежде, что она будет полезной, но
БЕЗ КАКИХ-ЛИБО ГАРАНТИЙ; даже без подразумеваемых гарантий
КОММЕРЧЕСКОЙ ЦЕННОСТИ или ПРИГОДНОСТИ ДЛЯ КОНКРЕТНОЙ ЦЕЛИ. Для получения
подробных сведений смотрите Универсальную Общественную Лицензию GNU.

Вы должны были получить копию Универсальной Общественной Лицензии GNU
вместе с этой программой; если нет, напишите в Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.

Добавьте также сведения о том, как связаться с вами по электронной и обычной почте.

Если программа интерактивная, сделайте так, чтобы при запуске в интерактивном режиме она выдавала краткое уведомление типа следующего:

Gnomovision версия 69, Copyright (C) год имя автора
Gnomovision поставляется АБСОЛЮТНО БЕЗ КАКИХ-ЛИБО ГАРАНТИЙ; для
получения подробностей напечатайте `show w'.Это свободная программа, и
вы приглашаетесь повторно распространять ее при определенных условиях;
для получения подробностей напечатайте `show c'.

Гипотетические команды show w и show c должны показывать соответствующие части Универсальной Общественной Лицензии. Конечно, используемые вами команды могут вызываться как-нибудь иначе, нежели show w и show c; они даже могут выбираться с помощью мыши или быть пунктами меню --- все, что подходит для вашей программы.

Вы также должны добиться того, чтобы ваш работодатель (если вы работаете в программистом) или ваше учебное заведение, если таковое имеется, подписали в случае необходимости "отказ от имущественных прав" на эту программу. Вот образец; замените фамилии:

Yoyodyne, Inc., hereby disclaims all copyright
interest in the program `Gnomovision'
(which makes passes at compilers) written
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

Данная Универсальная Общественная Лицензия не позволяет вам включать вашу программу в программы, являющиеся частной собственностью. Если ваша программа --- это библиотека процедур, вам стоит подумать, не будет ли лучше разрешить программам, являющимся частной собственностью, связываться с вашей библиотекой. Если это то, чего вы хотите, используйте вместо этой Лицензии Универсальную Общественную Лицензию GNU для библиотек.


Системные требования

InfraRecorder
Системные требования

InfraRecorder имеет следующие системные требования:

  • Windows 95 с Internet Explorer 5.0 или новее.
  • 32 Мб RAM.
  • 8,1 Мб свободного места на жестком диске.


Быстрый старт

InfraRecorder
Быстрый старт

Как использовать?

С чего начать?
Мультисессионные диски
Копирование дисков с данными
Копирование аудио дисков
Очистка перезаписываемых дисков
Просмотр информации о диске
Конфигурация устройств


Копирайт

InfraRecorder
Копирайт

InfraRecorder копирайт © 2006-2008 Christian Kindahl.

InfraRecorder использует при работе следующее программное обеспечение:

  • cdrecord, readcd копирайт © 1995-2006 Jörg Schilling.
  • cdda2wav от Project MODE и Fraunhofer Institut für integrierte Schaltungen.


Благодарности

InfraRecorder
Благодарности

В InfraRecorder используются иконки и производные продукты, основанные на иконках из Tango Icon Project. Производные продукты, основанные на Tango Icons можно закачать отдельно (на условиях Creative Commons Attribution Share-Alike license) с оффициального вебсайта Infra Recorder.


Что нового?

InfraRecorder
Что нового?

Версия 0.45.0.0

  • cdrtools обновлён до версии 2.01.01a38.
  • Исправлен дефект, приводящий к падению InfraRecorder при попытке перемещения каталога в самого себя.
  • Исправлен дефект, приводящий к открытию неправильного каталога при двойном клике в структуре диска, содержащей каталоги с одинаковыми именами.
  • Исправлен дефект, из-за которого фокус не возвращался кнопке OK в окне прогресса выполнения после окончания операции.
  • Исправлен дефект отрисовки значков на системах Windows XP и выше, где установлена глубина цвета менее 32 бит.
  • По-умолчанию опция "Производить скрытую проверку конфигурации при каждом старте" включена.
  • Добавлена поддержка ассоциации InfraRecorder с образами дисков.
  • Некоторые диалоговые окна обновлены для возможности минимизации и отображения на панели задач при их запуске из внешних приложений (таких как, например, irExpress).
  • Исправлен дефект, приводящий к использованию неправильных имён файлов при проверке записанного диска.
  • Добавлена возможность для переименования и удаления файлов из импортированных сессий.
  • Добавлена возможность выбора мультисессионного трека для импорта.
  • Теперь при записи непустого перезаписываемого диска InfraRecorder предлагает его очистить.
  • Теперь при выполнении операции на панели задач отображается её прогресс.
  • Уменьшено потребление памяти при работе с проектами.
  • Исправлен дефект, приводящий к невозможности открытия сохранённого проекта, не содержащего файлов.
  • Добавлен перевод на тайский язык, сделанный Prasit Kaephukhieo!
  • Улучшена совместимость со стандартами ISO9660.
  • Добавлена возможность создания файловой системы UDF-only.
  • Добавлена поддержка Юникод для имён файлов в расширении Joliet и файловой системе UDF.
  • Добавлена поддержка фрагментированных файлов для ISO9660 уровня 3. Теперь файлы с размером более 4 Гб могут быть записаны в файловую систему ISO9660.
  • Удалены зависимости от mkisofs и isoinfo.
  • Исправлены некоторые ошибки, связанные с импортированными сессиями дисков.
  • Добавлен пункт меню "Свойства", вызываемый правым кликом на корневом элементе структуры диска.
  • Добавлено корректное выделение скрытых файлов на файловой системе диска.
  • Изменён метод записи мультисессионных дисков по-умолчанию на TAO.
  • Исправлен дефект, приводящий к падению InfraRecorder при переименовании файлов проекта с использованием символов прямого и обратного слеша.
  • В список поддерживаемых расширений имён образов добавлено расширение .img.
  • Произведено несколько косметических изменений.
  • Добавлен перевод на арабский язык, сделанный Circoficus!
  • Добавлен перевод на греческий язык!

Версия 0.44.1.0

  • Введены альтернативные методы получения скоростей привода для записи.
  • Добавлена поддержка перезагрузки приводов ноутбуков (эти приводы не могут загружать лоток самостоятельно) до начала процесса проверки диска.
  • Исправлен дефект отображения номера версии в системе лог-отчётов.

Версия 0.44.0.0

  • Добавлено предупреждающее сообщение при отключении функции "Фиксировать диск после записи", потому что некоторые пользователи считают, что это создаст мультисессионный диск.
  • Теперь возможно производить копирование дисков используя одно устройство в качестве источника и приёмника.
  • Изменён порядок определения скорости привода, теперь она зависит от установленного носителя.
  • Улучшено автообнаружение подключенных/отключенных устройств.
  • Добавлено переключение между главными элементами отображения с помощью клавиши "TAB".
  • Исправлен дефект, приводящий к падению InfraRecorder в системах Windows 9x при смене папки в окне Проводника.
  • Добавлен пункт меню для выделения всех файлов и инвертирования выделения.
  • Исправлен дефект, приводящий в некоторых случаях к отображению отрицательного прогресса.
  • Введена корректная обработка развёртывания окна InfraRecorder при запуске (если оно было закрыто развёрнутым).
  • Добавлена кнопка "Website" в окне "О программе InfraRecorder...".
  • Исправлен дефект переименования файла проекта.
  • Добавлено несколько типов отображения панели инструментов.
  • Теперь в проекте не может быть одинаковых файлов или папок.
  • Теперь конфигурация сохраняется в каталоге программы. Новая портативная версия InfraRecorder позволяет определить, где именно в каталоге программы сохранять настройки.
  • Сильно улучшена функциональность Drag and Drop.
  • Добавлен перевод на норвежский язык, сделанный Karol Ptasinski!
  • Изменён файл справки для улучшения поиска.
  • Исправлен дефект, приводящий к попытке InfraRecorder проверить файлы, которые были импортированы из предыдущих сессий.
  • Исправлен дефект, приводящий к извлечению диска (если установлена соответствующая опция) до начала процесса его проверки.
  • Исправлен дефект, приводящий к несовместимости с системами Windows 9x (вызов функции SHGetFolderPathA).

Версия 0.43.1.0

  • cdrtools обновлён до версии 2.01.01a26.
  • Добавлен перевод на финский язык, сделанный Rami Aalto!
  • Удалено сообщение об ошибке, связанное с ckEffects.exe.
  • Улучшена функция стирания диска (соответсвенно увеличено число поддерживаемых приводов).
  • Исправлен дефект, из-за которого размер и позиция главного окна на сохранялись.
  • Исправлен дефект, приводящий к заливке окна Проводника белым при двойном клике на каталоге (только Windows XP).
  • Улучшена функциональность системы лог-отчётов.
  • Исправлен дефект, приводящий к невозможности импорта сессий с определённых типов дисков.
  • Увеличена скорость отображения дерева каталогов в окне Проводника (разворачивание дерева под значком "Мой компьютер" на некоторых системах приводило к длительному ожиданию из-за медленного опроса приводов гибких дисков).

Версия 0.43.0.0

  • Исправлен дефект, приводящий к ошибке при изменении порядка следования аудио треков.
  • Добавлен эффект тумана при записи диска (требует Windows Vista Aero).
  • Исправлены дефекты, приводящие к отображению неправильной информации о диске.
  • Адаптация для Windows Vista.
  • Добавлена возможность бросать файлы в Структуру диска (используя Drag and Drop).
  • Полность переписан код стирания/форматирования диска. Улучшена поддержка дисков DVD±RW и DVD-RAM.
  • Добавлен перевод на каталанский язык, сделанный Josep Lluнs Amador Teruel!
  • Добавлен перевод на галльский язык, сделанный Xesas Estuvez!
  • Исправлен дефект, приводящий к получению неправильных координат главного окна InfraRecorder, если его закрыть свёрнутым.
  • Добавлен перевод на румынский язык, сделанный Nicolae Crefelean!
  • Удалена зависимость от Visual C++ 8 DLL.
  • Добавлен перевод на венгерский язык, сделанный Tibor Sorkony!
  • Добавлен перевод на еврейский язык, сделанный Shemesh!
  • Добавлен перевод на датский язык, сделанный Patrick Fust!
  • Исправлен дефект, из-за которого ни одна внутренняя команда SCSI не выполнялась в сборке InfraRecorder для x64.

Версия 0.42.1.0

  • Теперь MSI-установщик для сборки x64 создаёт значки в стартовом меню в подпапках.
  • Исправлен дефект, приводящий к падению InfraRecorder, когда cdrecord возвращает число записанных треков больше, чем их отправлено на запись.
  • Удалена зависимость от Visual C++ 8 DLL из кодека irWave.
  • Исправлен дефект, приводящий к переполнению стека при использовании кодека irWMA.

Версия 0.42.0.0

  • Доступна сборка для 64-битных систем (x64).
  • Создан новый кодек Wave для удаления зависимости от libsndfile и совместимости с компилятором x64.
  • Изменена система поддержки перевода (теперь элементы управления автоматически изменяют свой размер и компонуются, если необходимо).
  • Различные изменения для совместимости с Windows Vista.
  • Изменён кодек WMA (теперь не появляется сообщение об ошибке при его неудачной загрузке (если Windows Media Player не установлен)).
  • Добавлен перевод на японский язык, сделанный Nardog!
  • Исправлен дефект, из-за которого носители DVD всегда записываются на максимальной скорости.
  • Добавлен перевод на корейский язык, сделанный Jung Jin-ho!
  • Добавлен перевод на болгарский язык, сделанный Iliyan Popov!
  • Теперь проекты "DVD с данными" и "CD с данными" разделены.
  • Добавлена поддержка имён файлов для упущенных версий ISO9660.
  • Добавлена возможность использования расширения Rock Ridge без необходимости использования расширения Joliet.
  • Исправлен дефект, приводящий к неправильному значению скорости записи на некоторых приводах.
  • Добавлена возможность сортировки по столбцам.
  • Добавлена возможность изменения порядка следования аудио треков с помощью Drag and Drop.
  • Добавлен перевод на сербский язык (кириллица и латынь), сделанный ozzii!
  • Добавлена возможность автоматической проверки диска после записи.
  • Применено двойное буферезирование текстовых меток в диалогах прогресса, чтобы избежать их мерцания.
  • Исправлен дефект, приводящий к неправильному обнаружению кодовой страницы cp1250 на системах с чешским языком.
  • Добавлена возможность создания проектов видео DVD.
  • Добавлен перевод на словакский язык, сделанный Marek!
  • Исправлен дефект, приводящий к проблемам при импорте определённых сессий с мультисессионного диска.
  • Исправлен дефект, приводящий к неправильному сбросу установок UDF при создании нового проекта.
  • Исправлен дефект, приводящий к неправильному отображению сообщений об ошибках во время записи проекта "на лету".
  • Добавлен перевод на китайский язык (T), сделанный Charlie!

Версия 0.41.0.0

  • Исправлен дефект, приводящий к отображению неправильного размера аудио файлов в смешанных проектах.
  • Из-за ограничений Microsoft Windows 9x Unicode Layer, не юникод-версия InfraRecorder распространяется отдельно.
  • Добавлена возможность отключения сообщения об ошибке, возникающей при неудачной загрузке кодека.
  • Добавлена поддержка совместимой с видео DVD файловой системы.
  • Добавлена поддержка UDF.
  • Добавлена возможность создания загрузочных дисков.
  • Исправлена серьёзная ошибка, приводящая к невозможности корректной загрузки некоторых проектов.
  • Добавлен перевод на боснийкий язык, сделанный Asim Husanovic!
  • Добавлена возможность изменения обнаруженной скорости записи привода.
  • Изменено управление скоростями привода (теперь для записи можно использовать большее количество скоростей, включая максимальную).
  • На вкладку "Дополнительно" (окна информации о устройстве) добавлена информация о методе записи.
  • Исправлен дефект, приводящий к обнаружению неправильного набора символов при использовании кодовой страницы 1251.
  • Исправлен дефект, приводящий к установке фиктивных прав доступа для файлов UNIX при записи некоторых проектов с использованием расширения Joliet.
  • Улучшена рабочая область окна проекта.
  • Добавлена возможность записи проектов "на лету".
  • Исправлен дефект, из-за которого после операции копирования диска временные файлы не удалялись.
  • Добавлена возможность отключения сообщения об ошибке о неподдерживаемом наборе символов.
  • Исправлен дефект, приводящий к отображению размера аудио проекта в байтах, а не минутах.
  • Добавлен перевод на словенский язык, сделанный Frani Ћiћek!
  • Добавлен перевод на украинский язык и справка, сделанные Serhij Dubyk!
  • Теперь дополнительные свойства устройства, если их длина слишком велика для отображения, показываются во всплывающих подсказках.
  • Исправлен дефект, из-за которого пустые каталоги игнорируются при создании и записи проектов.
  • Исправлен дефект, из-за которого появляется ошибка при создании образа диска, имеющего файлы с одинаковыми символами в имени.
  • Добавлен перевод на португальский язык, сделанный Uder Silva!
  • Добавлен перевод на китайский язык (S), сделанный DouDeHou!
  • Добавлено больше опций чтения (игнорировать ошибки чтения, считывать все субканальные данные и TOC, скорость чтения).
  • Добавлена поддержка копирования дисков.
  • Добавлена возможность изменения размера буфера FIFO.
  • Добавлена поддержка ISO уровня 4, которая допускает глубину вложения папок более восьми.

Версия 0.40.0.0

  • Добавлен перевод на чешский язык, сделанный khagaroth!
  • Улучшена поддержка DVD дисков (официальный cdrtools поддерживает DVD с версии 2.01.01a09).
  • Режим симуляции теперь работает и при записи DVD дисков.
  • Поддержка очистки DVD+RW носителей (пока только для Ricoh приводов).
  • Размер и положение главного окна Infra Recorder теперь запоминается и восстанавливается при каждом запуске программы.
  • Добавлен перевод на баскский язык, сделанный David Garcнa-Abad!
  • Добавлена поддержка кодирования аудио дорожек в Ogg, WMA и MP3 (отдельным пакетом из-за проблем с патентом).
  • Исправлен дефект, приводивший к отображению неверных дорожек при сканировании на наличие ошибок.
  • Добавлена поддержка декодирования MP3, Ogg и WMA аудио.
  • Добавлена Справка на немецком языке, перевод сделал CE4!
  • Добавлена Справка на русском языке, перевод сделал Roman Starikh!
  • Добавлен перевод на итальянский язык, сделанный Lorenzo Festa!
  • Исправлен дефект в окнах сообщений.
  • Добавлена поддержка Справки на других языках.
  • По-умолчанию Симуляция теперь отключена.
  • Добавлена опция, позволяющая выбирать временную папку.
  • В Справку добавлена информация о том, как выполнить автоматическую установку Infra Recorder.
  • Установщик теперь добавляет запись в "Удалении и установке программ".
  • Добавлена поддержка выбора языка установки при автоматической установке.
  • Добавлен перевод на русский язык, сделанный Roman Starikh!
  • Добавлен перевод на немецкий язык, сделанный Thomas Bigler!
  • Добавлен перевод на польский язык, сделанный DJD!
  • Добавлен перевод на турецкий язык, сделанный Fatma Akarslan!
  • Добавлен перевод на хорватский язык, сделанный Tibor Keser!
  • Добавлен перевод на датский язык, сделанный Patrick!

Версия 0.31.0.0

  • Добавлен перевод на португальский язык, сделанный Cesar Baptista!
  • Добавлен перевод на испанский язык, сделанный Eduardo Leon!
  • Увеличена высота всех боксов в GUI, чтобы избежать ненужной прокрутки.
  • Исправлены некоторые глитчи GUI, вызывавшие появление черного и фиолетового фона у некоторой графики (имело место только в системах более старых, чем Windows XP).
  • Добавлена всплывающая подсказка в шкале, которая показывает размер проекта.
  • Добавлена поддержка вставки файлов из Проводника в проект.
  • Исправлена ошибка, приводившая к импорту нескольких сессий в проект.

Версия 0.30.0.83

  • Исправлена ошибка (статическая связь с UpdateLayeredWindow в user32.dll), приводившая к несовместимости с системами Windows 9x.

Версия 0.30.0.82 (Beta 2)

  • Добавлена поддержка DVD дисков посредством патчинга cdrecord (ВНИМАНИЕ: Режим симуляции при записи DVD дисков не работает).
  • Добавлен перевод на французский язык, сделанный Pierre-Jean Coudert!
  • Стандартный режим записи изменен на SAO из-за несовместимости с DVD дисками.
  • Обновлен установщик, добавлены дополнительные опции и мультиязычная поддержка.
  • Добавлено несколько новых переводимых строк в выводимых в отчет.
  • Внесены некоторые изменения в структуру каталогов в CVS.


Установка

InfraRecorder
Установка

Установщик InfraRecorder поддерживает различные опции/параметры для автоматической установки. Следующие параметры могут быть использованы при установке:

/S
Незаметная установка (или удаление). Все опции установки останутся стандарными, если не будут изменены другими параметрами установщика.

/LANGUAGE=<language>
Выбирает язык, который будет использовать InfraRecorder. Например: "irsetup.exe /S /LANGUAGE=russian" незаметно установит InfraRecorder, назначив в качестве языка по-умолчанию Русский.


С чего начать?

Как использовать?, Работа с проектами
С чего начать?

Этот топик поможет Вам создать Ваш первый проект CD. На данный момент InfraRecorder поддерживает три типа проектов.

Проекты дисков с данными позволяют создавать диски, содержащие файлы и папки (файловая система ISO9660), которые можно использовать практически на любом компьютере. Диски с данными содержат не так много информации в каждом секторе как аудио диски, в следствие того, что диски с данными, также содержат дополнительную информацию для проверки на ошибки и коррекции. В результате этого, диски с данными могут быть записаны на более высокой скорости без потери качества и данных. Диски с данными можно создавать в несколько этапов, что дает возможность добавлять данный на существующие CD диски. Дополнительную информацию по этому вопросу можно прочитать в этом топике.

Проекты аудио дисков позволяют создавать аудио диски, которые можно воспроизвести на любом CD проигрывателе (и компьютере). Обычно проекты аудио дисков следует записывать на более низкой скорости чем проекты дисков с данными, поскольку аудио диски не содержат никакой информации для проверки на ошибки и коррекции.

Проекты смешанных дисков позволяют создавать диски, которые содержат одну дорожку с данными, имеющую свойства Проекта диска с данными , и несколько аудио дорожек, следующих за ней. Смешанный дисx можно воспроизвести на любом CD проигрывателе, однако первая дорожка (с данными) будет звучать как шум. Аудио дорожки будут воспроизводиться как обычно.

Чтобы создать новый проект, воспользуйтесь меню:
Файл [image] Новый проект [image] <выберите тип проекта, который Вы хотите создать>
Чтобы открыть существующий проект, воспользуйтесь меню:
Файл [image] Открыть проект...
или кнопкой на панели инструментов:

Проекты Infra Recorder можно записывать как непосредственно на компакт-диск, так и в образ диска. Образ диска - это файл, который сохраняется в Вашем компьютере и содержит все файловые данные включенные Вами в проект (за исключением аудио дорожек в проектах смешанных и аудио дисков ). Образ диска можно записать позже. Дополнительную информацию можно прочитать в этом топике.

Чтобы записать проект на компакт-диск, воспользуйтесь меню:
Действия [image] Записать проект [image] На компакт-диск...
или кнопкой на панели инструментов:

Подробное описание опций записи можно прочитать в этом топике.

Интерфейс

Общие сведения

Панель Проводник предназначена для доступа к папкам и файлам и их добавления в проект.
Панель Структура диска предназначена для просмотра и управления проектом.

Работа с файлами

Меню Правка предназначено для управления проектом:
К опциям доступным в меню Правка (вверху), также можно получить быстрый доступ, кликнув правой кнопкой мыши в окне просмотра проекта. Например, если кликнуть правой кнопкой на папке, появится следующее меню:
Если Вы добавите в проект больше данных, чем способен вместить выбранный Вами носитель, шкала внизу окна покраснеет:
Шкала внизу станет оранжевой, когда Вы добавите в проект больше данных, чем способен вместить выбранный Вами носитель официально, но вероятно их можно будет записать, используя перепрожиг:

Вы можете изменить размер шкалы, чтобы она соответствовала реальному объему пустого диска, на который Вы собираетесь записать проект. Для этого, кликните правой кнопкой на шкале и выберите подходящий размер носителя.

Работа с файлами

Добавление файлов

Существует много разных способов, добавить файлы в проект. Вы можете воспользоваться методом drag and drop, просто перетащив файлы из окна Проводник программы или из Провдника Windows. Также, можно перейти в окне Проводник в нужную Вам папку и выбрать файлы, которые Вы хотели бы включить в проект.

После того, как Вы выбрали нужные файлы, можно воспользоваться меню:
Правка [image] Добавить [image] Выбранное
или кнопкой на панели инструментов окна Проводник:

Вы также можете выбрать нужную папку в окне Проводник и быстро добавить в проект все файлы и папки, содержащиеся в ней.

Чтобы добавить все файлы и папки из выбранной в окне Проводник папки, воспользуйтесь меню:
Правка [image] Добавить [image] Все
или кнопкой на панели инструментов окна Проводник:

Удаление файлов

Существует несколько способов, удалить файлы и папки из проекта. Один из них - нажать кнопку Del на клавиатуре. Вы, также, можете воспользоваться меню или кнопкой на панели инструментов.

Чтобы удалить файлы с помощью меню, выберите:
Правка [image] Удалить
можно, также, воспользоваться кнопкой на панели инструментов окна Структура диска:

Другие действия

Чтобы переименовать файл или папку, воспользуйтесь меню:
Правка [image] Переименовать
или кнопкой на панели инструментов окна Структура диска:
Чтобы добавить в проект новую пустую папку, воспользуйтесь меню:
Правка [image] Новая папка
или кнопкой на панели инструментов окна Структура диска:


Мультисессионный диск

Как использовать?, Работа с проектами
Мультисессионный диск

Мультисессионный диск - это диск, который содержит несколько сессий. Мультисессионный диск может быть записан в несколько этапов, по одной сессии за раз.

Создание новых мультисессионных дисков

Создать новые мультисессионные диски довольно просто. Чтобы создать новый мультисессионный диск, создайте новый проект диска с данными:
Файл [image] Новый проект [image] Диск с данныи
Откройте свойства проекта:
Файл [image] Свойства проекта...
Выберите вкладку ISO и измените Формат на:
Режим 2 XA (мультисессия)

Теперь Вы можете добавлять в проект файлы и папки как обычно. Дополнительную информацию о том, как работать с проектами, можно рочитать в этом топике.

Продолжение мультисессионных дисков

Чтобы добавить данные на существующий мультисессионный диск, Вы должны импортировать существующие сессии с данными в свой проект. Для этого, воспользуйтесь меню:
Действия [image] Импорт сессии...

В открывшемся окне Вы сможете выбрать устройство и посмотреть, сколько места занято и сколько доступно на диске. Если кнопка OK не активна, это означает, что диск невозможно импортировать.

После того, как Вы выберете устройство (привод), в которое Вы вставили мультисессионный диск, который Вы хотите импортировать, нажмите кнопку OK и данные будут импортированы в проект. Импортированные данные невозможно изменить или удалить с диска. Все импортированные файлы и папки отображаются в сером цвете.

Теперь Вы можете работать с новой сессией и добавлять новые данные на диск, либо воспользовавшись меню:
Действия [image] Записать проект [image] На компакт-диск...
или кнопкой на панели инструментов:


Настройки проекта

Как использовать?, Работа с проектами
Настройки проекта
Этот топик посвящен настройкам проекта, к которым можно получить доступ через меню:
Файл [image] Свойства проекта...

Общие настройки

Единственная настройка, которую Вы можете изменить на вкладке Общие - это метка диска. По умолчанию диску присваивается метка на основании даты и времени создания проекта. Пожалуйста, учтите, что к метке предъявляются те же требования, что и к имени файла в проекте (смотрите раздел Настройки ISO).

Настройки ISO

Уровень

Эта опция позволяет установить уровень соответствия ISO, который в основном задает различные уровни ограничения имени файла. InfraRecorder поддерживает четыре уровня:

  1. 1 уровень использует имена файлов в формате 8.3 (восемь символов, с трехсимвольным расширением), в верхнем регистре, с числами и подчеркиваниями. Максимальная глубина каталогов - восемь.
  2. 2 уровень допускает имена файлов длиной до 31 символа.
  3. 3 уровень допускает фрагментацию файлов (главным образом, при пакетной или инкрементной записи CD).
  4. 4 уровень на самом деле не существует, но когда выбрана ISO-9660:1999 (которая на самом деле ISO-9660 версии 2), то он используется. Этот стандарт позволяет файлам иметь длину имени до 207 символов, а каталогам иметь вложенность более восьми.

Кодировка

Позволяет выбрать кодировку, используемую в локальных именах файлов включенных в проект. Infra recorder попробует автоматически определить кодировку используемую в Вашей системе.

Формат

Эта опция определяет формат, который будет использован при записи проекта диска с данными на диск. Режим 1 обычно используется для записи обычных не мультисессионных дисков, в то время как Режим 2 следует использовать при создании мультисессионных дисков. Режим 1 допускает запись 2048 бит данных в каждый сектор, Режим 2 - 2336 бит данных в каждый сектор (Размер сектора CD-ROM - 2352 бит).

Другие настройки

Опция Иcпoльзoвaть Joliet (пoддepжкa длинныx имeн фaйлoв) добавляет на диск помимо обычных имен файлов ISO9660, сведения о каталогах Joliet. Обычно расширение joliet используется в Windows и допускает имена файлов в юникоде и длинной в 64 символа.

Если Вы хотите использовать еще более длинные имена файлов, Вы можете воспользоваться опцией Paзpeшить имeнa длинoй бoлee 64 cимвoлoв. Хотя это не совсем совместимо со спецификацией Joliet, похоже это работает. Максимальная длина имени файла равна 103 символам.

Название опции Пропускать номер версии в именах файлов (ISO9660) говорит само за себя.

Поля

Этот раздел включает опции, позволяющие указать данные о тех, кто трудился над проектом. Поля Издатель, Составил, Система и Тома можно редактировать по своему усмотрению, остальные поля часто содержат имена файлов, в силу ограничения в 36 знаков.

Аудио настройки

Этот раздел позволяет Вам задавать информацию CD-текста. CD-текст - это формат поддерживаемый некоторыми (многими?) CD проигрывателями, позволяющий отображать информацию о дорожке и исполнителе при воспроизведении диска. Эти опции доступны в проектах аудио и смешанных дисков.

Загрузочный диск

Эта секция доступна только в проектах с данными и позволяет Вам определить до 63 загрузочных образов, которые будут использованы для создания загрузочного диска "El Torito". Чтобы добавить новый загрузочный образ, щёлкните кнопку Добавить в проект новый загрузочный образ:


Добавление загрузочного образа

Как использовать?, Работа с проектами
Добавление загрузочного образа

Вот несколько опций, которые могут понадобиться Вам для настройки при добавлении загрузочного образа к проекту.

Имя

В этом поле указан путь к выбранному загрузочному образу. Путь указан от корневого каталога диска.

Эмуляция

Эта опция указавыет тип эмуляции, который будет использован в загрузочном диске "El Torino". Если тип эмуляции установлен в Флоппи диск, то загрузочный образ должен иметь размер 1200, 1440 или 2880 Кб. Если тип эмуляции установлен в Жёсткий диск, то загрузочный образ должен начинаться с MBR, содержащей один раздел. Использование типа Без эмуляции указывает системе загрузить и выполнить образ без какой-либо эмуляции.

Дополнительные опции

Опция Сделать образ незагрузочным позволяет не помечать диск как загрузочный. Система предусмотрит эмулированный привод для образа, но загружаться будет со стандартного устройства.

Опция Сегмент загрузки позволяет указать загружаемый сегмент адреса (в шестнадцатиричной форме) для неэмулируемых дисков "El Torito".

Опция Число секторов указать число виртульных (512 байт) секторов (в шестнадцатиричной форме) для загрузки в неэмулируемом режиме. Рекомендуется загружать весь загрузочный файл. Некоторые BIOS имеют проблемы с файлами, чей размер не кратен 4.


Запись образа

Как использовать?
Запись образа
Чтобы прожечь (записать) образ диска, Вы можете воспользоваться либо меню:
Действия [image] Записать образ...
или кнопкой на панели инструментов:

Вам будет предложено выбрать на жестком диске образ диска, который Вы хотите записать.

Настройки

Детальное описание доступных настроек можно прочитать в этом топике.


Настройки записи

Как использовать?
Настройки записи

Этот топик посвящен настройкам прожига (записи), которые появляются в разных местах в Infra Recorder, например, когда Вы собираетесь записать проект или образ диска, или сделать копию диска.

Хотя, как уже упоминалось выше, доступ к этим настройкам можно получить разными способами, они всегда выглядят одинаково:

Общие настройки

На лету

При записи "на лету" файловая система генерируется прямо во время записи, что может привести в появлению ошибок. Если опция отключена, то сначала на жёстком диске создаётся временный образ оптического диска и только затем происходит запись. По-умолчанию опция выключена, используйте её только при отсутствии достаточного количества места на диске.

Проверить диск после записи

Включение этой опции приводит к тому, что InfraRecorder проверяет код CRC, сравнивая файлы на жёстком диске и только что записанном оптическом диске, для подтверждения того, что запись прошла без проблем.

Скорость записи

Выберите скорость записи, которую Вы хотите использовать при записи диска. Если установить опцию Максимальная, будет автоматически выбрана самая высокая скорость поддерживаемая пишущим приводом.

Режим записи

Эта опция позволяет выбрать режим, который Вы хотите использовать для записи диска. В выпадающем списке будут доступны только те режимы, которые поддерживает Ваш пишущий привод.

Сессия за раз (SAO) часто, также, фигурирующий как Диск за раз (DAO), записывает все данные (включая lead-in и lead-out) за один проход, не допуская никаких прерываний потока данных. Впоследствии на диск невозможно добавить новые сессии или данные. Пожалуйста, учтите, что DVD диски следует записывать именно в этом режиме.

Дорожка за раз (TAO) записывает каждую дорожку отдельно, что требует записи связующих блоков между двумя дорожками. Старые приводы часто принудительно записывают двухсекундную паузу (pregap) между двумя дорожками, тогда как более новые приводы, как правило могут подстраивать размер pregap данных (смотрите опции описанные ниже).

TAO без паузы использует режим Дорожка за раз, описанный выше, и при этом пытается установить значение pregap на ноль, снижая размер связующих блоков между двумя дорожками до минимума.

Raw запись (raw96r) записывает данные в режиме raw, используя 2352-битные сектора, плюс 96 бит raw P-W субканальных данных, в результате чего размер сектора достигает 2448 бит. Это предпочтительный режим raw записи, поскольку он обеспечивает наилучший контроль за процессом записи CD дисков.

Raw запись (raw16) записывает данные в режиме raw, используя 2352-битные сектора, плюс 16 бит P-Q субканальных данных, в результате чего размер сектора достигает 2368 бит. Если привод не поддерживает raw96r режим raw записи, данный режим raw записи является предпочтительным. Данный режим записи не поддерживает CD-текст.

Raw запись (raw96p) записывает данные в режиме raw, используя 2352-битные сектора, плюс 96 бит raw P-W субканальных данных, в результате чего размер сектора достигает 2448 бит. Это наименее предпочтительный режим raw записи, главным образом из-за того, что его поддерживают лишь немногие приводы, и некоторые из них имеют дефекты в реализации микропрограмм. Не используйте этот режим, если Ваш привод поддерживает raw96r или raw16 режим raw записи.

Важно: Пожалуйста, учтите, что все режимы raw записи загружают CPU значительно больше, чем остальные режимы записи. Если у Вас слишком медленный CPU, у Вас могут возникнуть проблемы из-за опустошения буфера.

Другие настройки

Если включить опцию Симуляция, Infra Recorder выполнит выбранное действие, но при этом лазер привода будет выключен. Эту опцию рекомендуется использовать, если Вы не уверены в успехе операции.

Зaщитa oт oпycтoшeния бyфepa - это опция поддерживаемая более новыми приводами, которая позволяет продолжать процесс записи, даже если произошла ошибка опустошения буфера. Эта возможность часто имеет разные названия у разных производителей, например: Yamaha - связь без потерь (Lossless-Link), Sanyo - устойчивый прожиг (BURN-Proof), Ricoh - точная связь (Just-Link), и т.д.

Дoпoлнять дopoжки c дaнными - если эта опция включена, после каждой дорожки с данными записывается 15 нулевых секторов, а аудио дорожки дополняются до числа кратного 2352 битам. Возможно Эта опция может пригодиться Вам, если Вашему CD-приводу не удается считать последние секторы дорожки, или если Вы намерены использовать диск в файловой системе Linux ISO-9660, имеющей дефект опережающего чтения.

Если отключить опцию Фиксиpoвaть диcк после записи, последняя сессия (в режиме SAO) или дорожка (в режиме TAO) не будут зафиксированы (закрыты). Это опция может пригодиться Вам, если Вы хотите записать CD в несколько этапов.

Важно: Создание нефиксированного диска не имеет ничего общего с созданием мультисессионного диска.

Дополнительные настройки

Опция Paзpeшить пepeпpoжиг позволяет записывать на носитель больше его официального объема. Дело в том, что большинство пустых носителей, могут вмещать больше данных, чем заявлено официально, поскольку официальный размер области lead-out составляет 90 секунд (6750 секторов), тогда как диск обычно работает, если есть lead-out как минимум в 150 секторов. Следовательно, все носители можно перепрожигать, по крайней мере, на 88 секунд (6600 секторов). Большинство приводов поддерживают перепрожиг только в режиме SAO и raw записи. Некоторые приводы могут ограничивать предельный размер диска до определенной величины, не позволяя Вам перепрожигать столько, сколько Вы считаете нужным. Эту проблему можно обойти, записывая CD диск в режиме raw, поскольку при записи в таком режиме привод не в состоянии определить размер носителя, пока не начнется процесс записи.

Если опция Пoмeнять битoвый пopядoк включена, аудио данные воспринимаются, как идущие в byte-swapped (little-endian) порядке. Некоторые приводы, например от Yamaha, Sony и новые SCSI-3/MMC приводы требуют, чтобы аудио данные были представлены в little-endian порядке, тогда как остальные приводы требуют от аудио данныхbig-endian (network) расположения битов, обычно используемого SCSI протоколом. Порядок расположения битов, требуемый Вашим приводом, будет распознан автоматически. Единственная ситуация, когда Вам может понадобиться эта опция - это, если Ваш поток данных имеет Intel (little-endian) порядок.

Опцией Игнopиpoвaть paзмep нocитeля можно воспользоваться, если Вы хотите проигнорировать известный размер носителя. Эту опцию следует использовать с особой острожностью. Опция улучшает перепрожиг.

Опция Уcтaновить IMMED флaг для SCSI, как и следует из ее названия, устанавливает IMMED флаг для определенных SCSI команд. Установка IMMED флага потребует от команд безотлагательного ответа, в то время как выполнение операции продолжится в фоновом режиме, освобождая шину для других устройств и избегая "зависания" системы. Эта опция может пригодиться на поврежденных системах с жестким диском ATAPI и CD/DVD-приводом, или с одинаковыми шинами, или с SCSI системами, которые не поддерживают disconnect/reconnect. Такие системы будут "зависать" при очистке или фиксации диска, или во время минимального заполнения сессии. Пожалуйста, учтите, что не все приводы поддерживают IMMED флаг.

Yamaha Audio Master Q. R. используется для создания высококачественных аудио дисков, которые вызывают меньше проблем при воспроизведении на Hi-Fi проигрывателях. Эта опция предполагает использование режима записи Сессия за раз (SAO). Эта опция работает не на всех скоростях, и не позволяет записывать на диск такой же объем информации, вследствие того, что паузы на CD будут больше чем обычно. Если эта опция включена, 74-минутный CD будет иметь объем 63 минуты, а объем 80-минутного CD сократится до 68 минут. Эту опцию можно использовать, также и при записи дисков с данными.

Уcкopeнный peжим заставляет привод использовать выбранную скорость записи, независимо от качества носителя. Обычно современные носители имеют информацию о наивысшей допустимой скорости для различных носителей и могут снижать скорость записи, чтобы гарантировать наилучшее качество записи. Эту опцию следует использовать с осторожностью, поскольку привод обычно знает лучше, какой носитель можно записывать на максимальной скорости.

Зaпиcь в peжимe Plextor VariRec позволяет пользователю слегка подстраивать мощность лазера. При правильной настройке, это может снизить дрожь, способствуя улучшению качества звука, "читабельности" и совместимости с существующими CD проигрывателями. VariRec работает только на четвертой скорости.


Настройки чтения

Как использовать?
Настройки чтения

На этой странице содержится информация о настройках чтения, которые могут быть использованы в различных частях InfraRecorder, например при копировании диска в образ или на другой диск.

В общем, все эти опции доступны во множетве контекстов (как показано выше), но они имеют одинаковый смысл:

Опции чтения

Игнорировать ошибки чтения

Включение этой опции приводит к проверке на высокоуровневые ошибки и позволяет продолжать чтение потока данных, даже если в нём обнаружены критические нарушения. Привод переключается в режим игнорирования ошибок чтения в секторах данных, которые являются результатом неустранимых ошибок кодов ECC/EDC.

Считывать все субканальные данные и TOC

Когда эта опция включена диск будет прочитан со всеми субканальными данными и TOC. Сам TOC помещается в файл с именем образа и расширением .toc.

Скорость

Позволяет выбрать скорость, используемую при чтении диска. Выбор опции Максимальная автоматически выберет наибольшую скорость, из поддерживаемых приводом. Только MMC -совместимые приводы поддерживают эту опцию. Скорость несовместимых с MMC приводов не меняется.

Использование минимальной скорости увеличивает читаемость диска.


Копирование аудио диска

Как использовать?
Копирование аудио диска
Для копирования аудио диска требуетcя выполнить больше шагов, чем при копировании диска с данными. Вначале, Вы должны сохранить аудио дорожки на жестком диске. Для этого, откройте диалог Дорожки через меню:
Действия [image] Управление дорожками...
После того, как Вы выберете привод источник и вставите аудио диск, окно должно выглядеть как на этом скриншоте:
Теперь выберите дорожки, которые вы хотите сохранить (скопировать), кликнув при нажатой кнопке Shift или Ctrl. После того, как дорожки выбраны, нажмите кнопку Сохранить дорожки:

Вам будет предложено выбрать папку для сохранения дорожек. Пожалуйста, выберите папку по своему усмотрению. После того, как Вы выберете папку, все выбранные Вами дорожки будут сохранены в ней (при условии, что не произойдет серьезных ошибок чтения).

Следующий шаг - создайте аудио проект, и добавьте в него сохраненные Вами дорожки. Дополнительную информацию можно прочитать в этом топике.


Копирование диска с данными

Как использовать?
Копирование диска с данными

Пожалуйста, учтите, что на этой странице содержится информация о том, как скопировать диск с данными. Если вы хотите скопировать аудио диск (что является абсолютно другим процессом), пожалуйста, смотрите этот топик.

При копировании диска с данными доступны два основных режима, позволяющие, по желанию, копировать диск непосредственно на другой привод (например с CD-привода на CD-привод) или в образ диска на жесткий диск.

Копирование на компакт диск

Чтобы скопировать диск непосредственно на другой привод, воспользуйтесь меню:
Действия [image] Копировать диск [image] На компакт-диск...
или кнопкой на панели инструментов:

Источник

Выберите привод источник, содержащий компакт диск, копию которого Вы хотите сделать.

Приемник

Выберите привод приемник, содержащий пустой компакт диск, на который Вы хотите записать копию диска. Пожалуйста, учтите, что в качестве привода приемника нельзя выбрать привод источник.

Копирование на лету

Под копированием "на лету" подразумевается чтение данных с привода источника, и их последующая запись непосредственно на привод приемник (пишущий привод), без буферизации на жестком диске (используется только относительно небольшой буфер памяти). Если привод источник не сможет считать некоторые секторы диска источника, он будет не в состоянии обеспечивать привод приемник (пишущий привод) данными для записи с необходимой скоростью, что приведет к ошибкам записи диска приемника. Однако большинство современных пишущих приводов поддерживают технологию, обеспечивающую так называемую защиту от опустошения буфера, цель которой защитить диск приемник если такое опустошение буфера все-таки произойдет.

Если опция Копирование на лету отключена, вначале на жестком диске будет создан временный образ диска. Затем, этот образ диска будет записан на привод приемник. Хотя, эта опция требует наличия большего объема свободного места на жестком диске, в большинстве случаев рекомендуется использовать именно ее.

Клонирование

Когда эта опция включена все субканальные данные и TOC на источнике будут скопированы в приёмник. Эта опция обязательно должна быть включена при копировании смешанных дисков, иначе будут скопированы только треки с данными. При этом рекомендуется использовать метод записи RAW96r. Если он не поддерживается Вашим приводом, то попробуйте использовать метод записи RAW16.

Настройки чтения

Настройки чтения описаны в этом топике.

Другие настройки

Другие настройки описаны в этом топике.

Копирование в образ диска

Чтобы скопировать диск в образ диска на жесткий диск, воспользуйтесь меню:
Действия [image] Копировать диск [image] В образ диска...

Источник

Выберите привод источник, содержащий компакт диск, копию которого Вы хотите сделать.

Файл образа

Выберите расположение и имя образа диска. Пожалуйста, учтите, что Вам понадобится приблизительно столько же свободного места на жестком диске, сколько содержит компакт диск.

Настройки чтения

Настройки чтения описаны в этом топике.


Информация о диске

Как использовать?
Информация о диске
Чтобы посмотреть подробную информацию о диске, воспользуйтесь меню:
Действия [image] Информация о диске [image] <выберите привод содержащий интересующий вас диск>

Поля

Тип диска - показывает тип диска вставленного в привод. Например: CD-R, DVD+R DL.

Формат - действительно только для DVD дисков, и показывает формат (Book type) DVD.

Регион - показывает код региональной защиты DVD. Региональные коды имеют следующие значения:

  1. Соединенные Штаты Америки, Канада.
  2. Европа, включая Францию, Грецию и Турцию, Египет, Аравия, Япония и Южная Африка.
  3. Корея, Таиланд, Вьетнам, Борнео и Индонезия.
  4. Австралия и Новая Зеландия, Мексика, Карибские о-ва, и Южная Америка.
  5. Индия, Африка, Россия и бывшие страны СССР.
  6. Народная республика Китай.
  7. Не используется.
  8. Авиалинии и круизные корабли.
  9. Расширение (часто используется для всерегиональных дисков).

Слои - показывает количество слоев диска.

Дорожки - показывает количество дорожек на диске.

Сессии - показывает количество сессий на диске.

Состояние - показывает информацию о диске, о состоянии последней сессии, а также, информацию о том, перезаписываемый диск или нет.

Занято - показывает объем использованного места на диске.

Свободно - показывает объем свободного места на диске.


Очистка диска

Как использовать?
Очистка диска
Чтобы очистить перезаписываемый диск, воспользуйтесь либо меню:
Действия [image] Очистить диск...
или кнопкой на панели инструментов:

Привод

Пожалуйста, выберите привод, который Вы хотите использовать для очистки диска.

Способ очистки

Выберите один из четырех способов очистки. Полная очистка диска - уничтожит все данные содержащиеся на диске. Эта операция может занять довольно много времени. Быстрая очистка диска - просто очистит оглавление (TOC), PMA и пауз. При этом сами данные в основном никогда не удаляются с диска (они просто становятся недоступными). Вместо этого они перезаписываются при следующей записи. Этот способ очень быстрый, в большинстве случаев он занимает около 10 секунд. С помощью способа Открыть последнюю сессию, можно открыть последнюю сессию закрытого мультисессионного диска, чтобы иметь возможность добавлять на него другие сессии. Последний способ - Стереть последнюю сессию, просто стирает последнюю сессию на диске. Сколько времени это займет, зависит от размера последней сессии.

Другие настройки

Если оглавление диска (TOC) по каким-либо причинам было повреждено, Infra Recorder не сможет очистить диск, пока не будет включена опция Игнорировать ошибки TOC.

Если включить опцию Симуляция, Infra Recorder выполнит выбранное действие, но при этом лазер привода будет выключен. Эту опцию рекомендуется использовать, если Вы не уверены в успехе операции.


Фиксация диска

Как использовать?
Фиксация диска
Фиксированный диск - это диск, который считается завершенным. Обычно фиксация производится автоматически, после записи данных на диск. Эта функция может быть полезна, если данные были записаны, но диск по каким-либо причинам не был фиксирован. Чтобы фиксировать диск, воспользуйтесь меню:
Действия [image] Фиксировать диск...

Привод

Пожалуйста, выберите привод, содержащий диск, который Вы хотите фиксировать.

Другие настройки

Если включить опцию Симуляция, Infra Recorder выполнит выбранное действие, но при этом лазер привода будет выключен. Эту опцию рекомендуется использовать, если Вы не уверены в успехе операции.


Управление треками

Как использовать?
Управление треками
Функция Управление треками позволяет просматривать содержащуюся в оглавлении (TOC) диска информацию. Она, также, предоставляет возможность сохранять и проверять на наличие ошибок выбранные треками. Чтобы открыть диалог управления треками, воспользуйтесь меню:
Действия [image] Управление треками...

Выберите треками, с которыми Вы хотите работать, кликнув мышью при нажатой кнопке Shift или Ctrl. Вы, также, можете воспользоваться кнопками о стрелками на клавиатуре, для навигации и выбора трека из списка.

Если вы захотите сохранить треки на жестком диске, Вам будет предложено выбрать папку для сохранения. После чего, треки будут автоматически сохранены, и им будет присвоено имя, основанное на номере трека и его типе (Track 1.wav, Track 2.iso). Чтобы сохранить выбранные треки на жесткий диск, нажмите кнопку Сохранить выделенный(ые) трек(и) на жёсткий диск:
Чтобы проверить выбранные треки на наличие ошибок, воспользуйтесь кнопкой Проверить выделенный(ые) трек(и) на наличие ошибок:

Скриншот

Результаты проверки трека с данными:


Конфигурация устройств

Как использовать?
Конфигурация устройств
Если Вы изменили конфигурацию своего оборудования, Вы, вероятно, захотите уведомить об этом Infra Recorder. Чтобы открыть окно конфигурации устройств Infra Recorder, воспользуйтесь меню:
Настройка [image] Устройства...

Вы увидите список устройств, опознанных Infra Recorder. Если Вы хотите обновить конфигурацию, нажмите кнопку Обновить. Это заставит Infra Recorder выполнить полное сканирование системы, и собрать информацию о всех поддерживаемых устройствах.

Если Вы хотите, чтобы Infra Recorder проверял конфигурацию в фоновом режиме при каждом запуске, включите опцию Производить скрытую проверку конфигурации при каждом старте.


Настройки

Как использовать?
Настройки
Чтобы получить доступ к настройкам InfraRecorder, воспользуйтесь меню:
Опции [image] Настройки...

Общие настройки

Опция Пpoвepять, включeн ли Aвтoзaпycк, пpи кaждoм cтapтe определяет, хотите ли Вы чтобы InfraRecorder проверял, включeн ли Aвтoзaпycк, пpи кaждoм cтapтe, или нет. Желательно, чтобы Автозапуск был отключен, поскольку, если его оставить включенным, Windows будет опрашивать CD-привод во время записи, что может привести к повреждению диска.

Если Вы хотите, чтобы Infra Recorder запоминал последнюю активную папку в окне Проводник, включите опцию Зaпoминaть пocлeднюю aктивнyю пaпкy. Вы, также, можете самостоятельно выбрать папку, которая будет открываться по умолчанию, при каждом запуске Infra Recorder.

Опция Временная папка позволяет указать каталог, который будет использоваться для хранения временных файлов на жёстком диске, например, файлов образов дисков. Не рекомендуется использовать разделы, на которых осталось мало свободного места.

Дополнительные настройки

Если Вы хотите включить ведение отчета Infra Recorder, воспользуйтесь опцией Becти отчет. Эта опция может быть полезной, для выявления возможных дефектов и ошибок в Infra Recorder. Не рекомендуется включать эту опцию, без особой необходимости, поскольку Infra Recorder требует больше памяти и сильней загружает CPU, когда включено ведение отчета.

Опция Включить эффект тумана включает или выключает эффект тумана, который появляется во время записи. Эффект тумана требует включённого Windows Vista Aero. Если он выключен, то никакого эффекта не проявится.

Опция Размер буфера FIFO позволяет указать размер буфера в оперативной памяти, который будет использоваться в дополнение к буферам приводов. Увеличение размера буфера обычно делает процесс записи более стабильным. Как правило размерop буфера FIFO должен быть не меньше размера буфера привода и не больше половины размера оперативной памяти. Если вы используете копирование "на лету", то тогда размер буфера должен быть большим (например, 128 Мб) для предотвращения опустошения буфера привода.

Настройки языка

Список доступных языков отображается в выпадающем списке. Чтобы сменить язык, просто выберите в выпадающем списке нужный язык, нажмите кнопку OK, и перезапустите Infra Recorder. Если нужный Вам язык отсутствует, проверьте, нет ли перевода на Ваш язык на домашней странице Infra Recorder.

Настройки интеграции

Интеграция (если она включена) добавляет дополнительные пункты в контекстное меню оболочки:

Эти опции позволяют записать образ диска и проекты InfraRecorder просто кликнув правой кнопкой мыши на них.

Расширение оболочки можно настроить на отображение пунктов в виде каскадного меню. Чтобы пункты меню отображались в виде каскадного меню включите опцию Кacкaднoe кoнтeкcтнoe мeню.

Можно, также, настроить расширение оболочки так, чтобы в меню не отображались значки, отключив опцию Пoкaзывaть в мeню знaчки.

Регистрация расширения оболочки

Расширение оболочки не работает автоматически с образами дисков и проектами Infra Recorder. После включения опции Bcтpoить InfraRecorder в кoнтeкcтнoe мeню Пpoвoдникa, InfraRecorder сообщает Проводнику Windows, что она предлагает другим приложениям использовать ее расширенные возможности.

Чтобы Проводник Windows мог использовать дополнительные возможности предоставляемые расширением оболочки InfraRecorder, это расширение должно быть зарегистрировано с типами файлов, которые позволят использовать дополнительные возможности.

В списке представлены встроенные расширения файлов. Чтобы ассоциировать расширение оболочки InfraRecorder с каким-либо типом файлов, просто отметьте в списке нужный пункт. Вы, также, можете добавить в список любые дополнительные типы файлов, нажав кнопку Добавить в список новое расширение: